PC SOFT
ONLINE REPOSITORY
FOR WINDEVWEBDEV AND WINDEV MOBILE

Home |  | Sign in | English US
Notifications Prowl
Published by floman321
in the category Tools
New features
Description
Prowl est un service qui permet d'envoyer des notifications (message) par Internet
Ces notifications peuvent être une information, un évènement ou un rappel de rendez vous !

Des applications clientes permettent de recevoir ces notifications sur Iphone, PC et mac

Site officiel : https://prowl.weks.net/
Prowl Pc : http://www.growlforwindows.com

Exemple d'utilisation avec Windev :
Remplacer les SMS d'informations sur Iphone (envoi gratuit)
Envoyer des informations sur les mise à jours.

-----------------------------------------------------------------------------------------

SI PAS Envoyer_Notification("Windev","AnEvent"+HeureSys,"esssai "+HeureSys,"2") ALORS
Erreur(ErreurInfo)
FIN

------------------------------------------------------------------------------------------

PROCEDURE Envoyer_Notification(LOCAL Titre est chaîne,LOCAL SousTitre est chaîne,LOCAL description est chaîne,LOCAL priority est chaîne = 0)

api_key est chaîne = "arecuperer_survotrecompte"; // https://prowl.weks.net/settings.php
reponse est chaîne = ""
url est chaîne = "https://prowl.weks.net/publicapi/add"

SI HTTPRequête(url,"","","apikey="+api_key+"&application="+Titre+"&event="+SousTitre+"&description="+description+"&priority="+priority) ALORS
reponse = HTTPDonneRésultat(HTTPRésultat)

SI Position(reponse,"error") > 0 ALORS
RENVOYER Faux
SINON
RENVOYER Vrai
FIN

SINON
RENVOYER Faux
FIN

Illustrations, screen shots
none
none
User reviews
(To evaluate this resource, click 'Write a review')
No review or comment? Be the first one!
ABOUT
RATING:
3.2520(20)
DOWNLOADS:
942
PUBLISHED:
July 19, 2009
VERSION:
CONCERNS:
WINDEV
Minimum version: 01F120056c
SIZE:
143.7 KB
OF SAME DEVELOPER